Arc Forumnew | comments | leaders | submitlogin
Problem with blog
1 point by jsgrahamus 2860 days ago | 1 comment
Trying to run blog.arc and I had the following problem.

I start arc372 in a command window:

Use (quit) to quit, (tl) to return here after an interrupt.

arc>

---

I then load blog.arc in that command window:

arc> (load "blog.arc")

nil

---

I then run bsv in the command window:

arc> (bsv)

ready to serve port 8080

---

When I point my browser to the above I get the following in my browser:

A Blog

archive | new post

---

When I click on "new post" I get the following in the browser:

You need to be logged in to do that.

Login

---

And the following in the terminal session:

open-input-file: cannot open input file: "C:/dev/urandom"

(The system cannot find the path specified.; errno=3)

=== context ===

rand-string

new-fnid

fnid

fnform

login-page

login-page

gs1760

gs1048

gs1048

handle-request-thread

---

I'm running this on Windows 7.

It seems that I am having problems when I try to enter a post. Not sure why.

Any ideas?

Thanks, Steve



1 point by hasenj 2859 days ago | link

Try the Anarki repository instead.

http://www.arcfn.com/2008/02/git-and-anarki-arc-repository-b...

> You need to be logged in to do that.

In the "how to run news" file, there are instructions to setup admin accounts, I'm guessing it might apply to the blog app as well.

https://github.com/nex3/arc/blob/master/how-to-run-news

> open-input-file: cannot open input file: "C:/dev/urandom"

It's trying to open '/dev/urandom' which is not valid on windows. (I don't know how to fix that).

-----