Arc Forumnew | comments | leaders | submitlogin
2 points by bogomipz 5929 days ago | link | parent

I feel rem is a strange name too, but don't feel rm makes it any better. Actually, as others have pointed out, the function isn't really necessary since

  (rem foo my-list)
can be written as

  (keep ~foo my-list)
Personally, I think select is a better name than keep, especially when you start using it on database tables, but that's just me.


4 points by almkglor 5928 days ago | link

Incidentally, keep is written (with some additional fooness) as:

  (def keep (test seq)
     (rem ~test seq))

-----

1 point by bogomipz 5926 days ago | link

Which proves that only one of them is necessary.

I'm sure the implementation could easily be reversed, so keep was the one that actually did the work.

-----