Is there a naming scheme for Arc? From reading the stuff that's already out there, I found `w/uniq`, which I suppose is shorthand for `with-unique` -- which means that, for consistency, all other "with"-type functions/macros should be "w/".
string-to-number, or string->number, or string->num, or str->num, or ston, or ...
1. Whatever's chosen needs to be consistent (i.e. it should always be "str" -- or "string" -- but not a mix).
2. When choosing, readability and terseness need to be balanced.
(I have a feeling this is really a new discussion, and if this does start to kick off, I'll start a new thread.)
[BTW, I do prefix my stuff (that I don't share -- so init code) with "daio/"; but if I was going to put it in a package, I'd use the package name and a hyphen (so "minesweeper-sweep", or whatever).]