Arc Forumnew | comments | leaders | submitlogin
1 point by shader 3216 days ago | link | parent

Would you guys prefer that the access function to the source table be named "src" or "source"? I don't know if src would cause any confilcts, but it fits with the current abbrev. style ;)


2 points by rntz 3216 days ago | link

It should be named 'source* . Naming conventions are a good thing. Abbreviation for things like this is unnecessary. Also 'src or 'source might be a good name for a macro to get the source of a given function, much like 'help is now:

    (mac src (name) `(source* ',name))

-----

1 point by shader 3215 days ago | link

That's almost exactly what I was thinking ;)

-----